Commune · Lieux
ENUM
Protocole réseau
ENUM, spécifié dans le RFC 6116 et RFC 6117, est un mécanisme permettant d'utiliser un numéro de téléphone comme clé de recherche dans le DNS pour trouver la manière de joindre une personne ou une autre entité. Les hypothèses de départ sont : qu'il existe déjà une infrastructure pour allouer les numéros de téléphone et que des milliards sont déjà attribués, que ces numéros sont des clés "naturelles" pour beaucoup de gens.
Sur Wikipédia
ENUM, spécifié dans le RFC 6116 et RFC 6117, est un mécanisme permettant d'utiliser un numéro de téléphone comme clé de recherche dans le DNS pour trouver la manière de joindre une personne ou une autre entité. Les hypothèses de départ sont : qu'il existe déjà une infrastructure pour allouer les numéros de téléphone et que des milliards sont déjà attribués, que ces numéros sont des clés "naturelles" pour beaucoup de gens. ENUM s'appuie sur le système DDDS ('Dynamic Delegation Discovery System', RFC 3401) et sur les enregistrements NAPTR du DNS. Une recherche ENUM par un résolveur ENUM commence par un numéro de téléphone à la norme UIT E.164, comme +33 1 23 45 67 89. Ce numéro est transformé en nom de domaine en l'inversant (comme on fait pour trouver un nom de domaine à partir d'une adresse IP, ici, cela donnerait 9.8.7.6.5.4.3.2.1.3.3.e164.arpa. On cherche alors les enregistrements NAPTR pour ce nom de domaine. Si on trouve (ici, avec dig) : % dig NAPTR 9.8.7.6.5.4.3.2.1.3.3.e164.arpa NAPTR 10 100 "u" "E2U+sip" "!^.*$!sip:[email protected]!" . NAPTR 10 102 "u" "E2U+msg" "!^.*$!mailto:[email protected]!" . Cela signifie que le titulaire du numéro de téléphone +33 1 23 45 67 89 peut être joint en SIP à [email protected] et par courrier électronique à [email protected]. La racine de ENUM est donc e164.arpa, géré politiquement par l'UIT et techniquement par le RIPE-NCC. On la nomme 'Tier 0' dans ENUM. Les 'Tier 1' sont les organismes nationaux d'attribution des numéros de téléphone et les 'Tier 2' les opérateurs. Ensuite, on peut déléguer comme on veut, comme avec n'importe quel domaine.
Texte : Wikipédia, CC BY-SA 4.0. · Image : Wikimedia Commons (Public domain) ·
Cartes voisines
-
C★★★
CEI 62443
Standard de sécurité informatique
-
★★★
Numéro de sécurité sociale en France
Identifiant personnel en France
-
5★★
555 (numéro de téléphone)
Numéro de téléphone
-
★★★★
Near-field communication
Communication radio établie entre des appareils en les rapprochant
-
★
RC5 (chiffrement)
Chiffrement par bloc
-
★★★
.um
Domaine de premier niveau
-
★
Table des caractères Unicode (10000-1FFFF)
Plan Unicode (U+10000-1FFFF)
-
E★
EDonkey2000
Protocole réseau
-
★
.pn
Suffixe national internet
-
★★
Plan de numérotation téléphonique en Chine
Description de l'organisation de la numérotation téléphonique chinoise
-
I★
ISO 6166
-
★
Liste de révocation de certificats
-
★★★
.info
Domaine de premier niveau
-
★★
Dénomination commune internationale
Format de noms de médicaments
-
★
61 (nombre)
Nombre entier naturel
-
★
.hn
Suffixe national internet
-
★
Table des caractères Unicode (30000-3FFFF)
Plan Unicode (U+30000-3FFFF)
-
★
Anemone (radar)
Radar aéronautique militaire