Commune · Lieux
ENUM
Protocole réseau
ENUM, spécifié dans le RFC 6116 et RFC 6117, est un mécanisme permettant d'utiliser un numéro de téléphone comme clé de recherche dans le DNS pour trouver la manière de joindre une personne ou une autre entité. Les hypothèses de départ sont : qu'il existe déjà une infrastructure pour allouer les numéros de téléphone et que des milliards sont déjà attribués, que ces numéros sont des clés "naturelles" pour beaucoup de gens.
Sur Wikipédia
ENUM, spécifié dans le RFC 6116 et RFC 6117, est un mécanisme permettant d'utiliser un numéro de téléphone comme clé de recherche dans le DNS pour trouver la manière de joindre une personne ou une autre entité. Les hypothèses de départ sont : qu'il existe déjà une infrastructure pour allouer les numéros de téléphone et que des milliards sont déjà attribués, que ces numéros sont des clés "naturelles" pour beaucoup de gens. ENUM s'appuie sur le système DDDS ('Dynamic Delegation Discovery System', RFC 3401) et sur les enregistrements NAPTR du DNS. Une recherche ENUM par un résolveur ENUM commence par un numéro de téléphone à la norme UIT E.164, comme +33 1 23 45 67 89. Ce numéro est transformé en nom de domaine en l'inversant (comme on fait pour trouver un nom de domaine à partir d'une adresse IP, ici, cela donnerait 9.8.7.6.5.4.3.2.1.3.3.e164.arpa. On cherche alors les enregistrements NAPTR pour ce nom de domaine. Si on trouve (ici, avec dig) : % dig NAPTR 9.8.7.6.5.4.3.2.1.3.3.e164.arpa NAPTR 10 100 "u" "E2U+sip" "!^.*$!sip:[email protected]!" . NAPTR 10 102 "u" "E2U+msg" "!^.*$!mailto:[email protected]!" . Cela signifie que le titulaire du numéro de téléphone +33 1 23 45 67 89 peut être joint en SIP à [email protected] et par courrier électronique à [email protected]. La racine de ENUM est donc e164.arpa, géré politiquement par l'UIT et techniquement par le RIPE-NCC. On la nomme 'Tier 0' dans ENUM. Les 'Tier 1' sont les organismes nationaux d'attribution des numéros de téléphone et les 'Tier 2' les opérateurs. Ensuite, on peut déléguer comme on veut, comme avec n'importe quel domaine.
Texte : Wikipédia, CC BY-SA 4.0. · Image : Wikimedia Commons (Public domain) ·
Cartes voisines
-
★
Anemone (radar)
Radar aéronautique militaire
-
★★
Hiérarchie numérique synchrone
Processus
-
F★★★
Flérovium
Élément chimique ayant le numéro atomique 114
-
D★
Dstny
Dstny est un acteur européen des télécoms et de l’IT, spécialisé dans les solutions de communications unifiées, téléphonie mobile, VoIP et connectivité.
-
★
.sn
Suffixe national internet
-
★
Indicatif régional 901
Indicatif téléphonique aux États-Unis
-
A★
Application-Layer Protocol Negotiation
-
★
Numberlink
-
★★★★
Point-to-Point Protocol
-
E★★
EDNS Client Subnet
Option in Extension Mechanisms for DNS
-
E★
Easy Approach to Requirements Syntax
-
D★★★★
DNS over HTTPS
Protocole pour exécuter des requêtes DNS via HTTPS
-
X★
XML-RPC
-
★★
SIPRNet
-
★
Indicatifs régionaux 419 et 567
-
★
Indicatif régional 320
-
★★★
911 (numéro d'appel d'urgence)
Numéro d'appel d'urgence nord-américain
-
★
Code INS
Numéro attribué par la Direction générale Statistique à chaque commune belge