UTF-7
UTF-7 (UCS ou Unicode transformation format 7 bits) est un codage de caractères informatiques à longueur variable conçu pour coder l’ensemble des caractères internationaux d’Unicode dans le courrier électronique de manière plus efficace que l’UTF-8 à l’aide de quoted-printable. UTF-7 n’est pas une norme Unicode, le standard Unicode ne mentionne que UTF-8, UTF-16 et UTF-32.
Nº Q276826 ★
Commune · Littérature
UTF-7
UTF-7 (UCS ou Unicode transformation format 7 bits) est un codage de caractères informatiques à longueur variable conçu pour coder l’ensemble des caractères internationaux d’Unicode dans le courrier électronique de manière plus efficace que l’UTF-8 à l’aide de quoted-printable. UTF-7 n’est pas une norme Unicode, le standard Unicode ne mentionne que UTF-8, UTF-16 et UTF-32.
Sur Wikipédia
UTF-7 (UCS ou Unicode transformation format 7 bits) est un codage de caractères informatiques à longueur variable conçu pour coder l’ensemble des caractères internationaux d’Unicode dans le courrier électronique de manière plus efficace que l’UTF-8 à l’aide de quoted-printable. UTF-7 n’est pas une norme Unicode, le standard Unicode ne mentionne que UTF-8, UTF-16 et UTF-32. UTF-7 est proposé pour la première fois comme protocole expérimental dans le RFC 1642, A Mail-Safe Transformation Format of Unicode (Un format de transformation d’Unicode sûr pour le courrier). Cet RFC est rendu obsolète par le RFC 2152, un RFC informel qui n’est jamais devenu une norme et qui spécifie clairement qu’il n’est pas une norme Internet. Malgré cela, le RFC 2152 est cité comme définition de l’UTF-7 dans la liste des codages de caractères de l’IANA. RFC 2060 définit une version modifiée parfois identifiée comme UTF-7, mUTF-7, et l’utilise dans le protocole IMAP.
Texte : Wikipédia, CC BY-SA 4.0. ·
Cartes voisines
-
U
UTF-8
Codage de largeur variable (sur un à quatre octets) et format de transformation des points de code pour le jeu de caractères universel défini par la norme ISO/CEI 10646 et le Standard Unicode®, compatible avec l'ASCII
Nº Q193537 ★★★★
Pas en vente
-
Base64
Type de codage binaire utilisant 64 caractères
Nº Q726780 ★★★★
Pas en vente
-
U
UTF-16
Format de transformation des textes codés avec une ou deux unités de code à 16 bits par caractère du jeu de caractères universel défini par la norme ISO/CEI 10646 et le Standard Unicode
Nº Q740701 ★★★
Pas en vente
-
U
UTF-32
Format de transformation des textes codés avec 4 octets par point de code dans le jeu de caractères universel défini par la norme ISO/CEI 10646 et le Standard Unicode
Nº Q736068 ★
Pas en vente
-
Unicode
Standard industriel permettant de coder, représenter et traiter de façon cohérente des textes exprimés dans la plupart des écritures du monde
Nº Q8819 ★★★★
Pas en vente
-
Byte
Unité de mesure informatique valant 8 bits
Nº Q8799 ★★★★
Pas en vente